Please enter your email address and we’ll send you a link to reset your password right away.

Your VIP area awaits in the APP

Log in to the app to manage your account, orders, and exclusive benefits.

Order tracking

Order tracking

Personalized notifications

Personalized notifications

Exclusive offers

Exclusive offers

Staying signed in lets you shop faster, check your orders, and access your favorites without signing in again.

Stay signed in
Log out
top

Sold and shipped by

sales

Free shipping

Return of order

Homepage

Zyxel GS1900-24-EU0102F switch

Price without code 146.99

RRP:

You save:

Price without subscription

VAT & duties included

No extra charges at delivery.

What is my size?

What is my size?

My virtual fitting room

My virtual fitting room

Single purchase

Add to my pack 

You save:

Buy now in 1 click
Back to PC configurator

Buy this product and earn

Color:

Free shipping

dto_trans discount on shipping

Free assembly

Free removal of old appliance (only with Ader)

Your interest-free financing from with Klarna Paypal

Pay in 3, 4, 6 or up to 12 installments

My virtual fitting room

Other colors available

left
right

Perfect pairings

left
right

Reportar error

Trusted by over 25 million satisfied customers worldwide

Official brand warranty

Quick & easy 30-day return

Features of Zyxel GS1900-24-EU0102F

Product description of Zyxel GS1900-24-EU0102F switch

Description summary

The Zyxel GS1900-24 is a 24-port Gigabit L2 managed switch offering robust performance for your network. Featuring a 52 Gbit/s switching capacity, 8000 MAC address entries, and comprehensive network standards support, it ensures efficient data transfer. Its fanless design and 1U rack-mountable form factor make it ideal for silent operation. Enhanced with VLAN, QoS, port mirroring, and strong security features like 802.1x RADIUS, this switch provides reliable connectivity and management for demanding environments. Includes EU plug and power supply

EU Plug.

Zyxel GS-1900-24 v2.

Switch Type:Managed, Switch Layer:L2.

Basic RJ-45 Ethernet switching type ports:Gigabit Ethernet (10/100/1000), Number of basic RJ-45 Ethernet switching ports:24.

Complete bidirectional (Full duplex).

MAC address table:8000 entries, Switching capacity:52 Gbit/s.

Network standards:IEEE 802.1D,IEEE 802.1p,IEEE 802.1s,IEEE 802.1w,IEEE 802.3,IEEE 802.3ab,IEEE 802.3af,IEEE.

Electrical connector:AC-in power connector.

Rack mounting, Form factor:1U.

Specifications:

-Quantity of basic RJ-45 Ethernet switching ports:24.

-Basic RJ-45 Ethernet switching type ports:Gigabit Ethernet (10/100/1000).

-Quantity of SFP module slots:2.

-Electrical connector:AC-in power connector.

-Width:440 mm.

-Depth:131 mm.

-Height:44 mm.

-Weight:2.09 kg.

-Power supply included:Yes.

-AC input voltage:100 -240 V.

-AC input frequency:50 -60 Hz.

-Power consumption (max):16 W.

-Power source:Alternating current.

-Operating temperature range:0 -50 °C.

-Relative operating humidity:10 -95%.

-Storage temperature range:-40 -70 °C.

-Storage relative humidity:10 -95%.

-Heat dissipation:55 BTU/h.

-Network standards:IEEE 802.1D, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.3, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x.

-Support 10G:No.

-Port mirroring:Yes.

-Complete bidirectional (Full duplex):Yes.

-Flow control support:Yes.

-Adding links:Yes.

-VLAN Support:Yes.

-Virtual LAN functions:Tagged VLAN,VLAN Identifier (VLAN ID),Voice VLAN.

-Supports MAC address auto-learning:Yes.

-Spanning tree protocol:Yes.

-Ethernet LAN, data transfer speed:10,100,1000 Mbit/s.

-MAC address table:8000 entries.

-Jumbo Frames, support:Yes.

-Switching capacity:52 Gbit/s.

-Jumbo frames:9000.

-Forwarding rate:39 Mpps.

-Save and forward:Yes.

-Package buffer:0.525 MB.

-Packet redirection speed (1 Gbps):39 pps.

-Cables included:Alternating current.

-Mounting shelf:Yes.

-Package weight:2.85 kg.

-Packing type:Box.

-Package width:561 mm.

-Package depth:217 mm.

-Package height:82 mm.

-DHCP.

Features:

DHCP client.

-IGMP:Yes.

-Supported security algorithms:802.1x RADIUS.

-MAC, address filter:Yes.

-SSH/SSL support:Yes.

-Static port.

Security:Yes.

-Authentication type:RADIUS,TACACS+.

-Password protection:Yes.

-Switch type:Managed.

-Quality of service (QoS) support:Yes.

-Web-based administration:Yes.

-Switch layer:L2.

-Registration of events in the system:Yes.

-MIB, support:RFC 1213 MIB II, RFC 2819 RMON (group 1, 2, 3, 9), RFC 1215, RFC 1493.

-Rack mounting:Yes.

-Product color:Black.

-LED indicators:Yes.

-Restore button:Yes.

Certification:EMC■ CE, FCC, C-Tick, Class A(GS1900-24/24EP/24HPv2/48/48HPv2)■ CE, FCC, C-Tick, Class B(GS1900-8/8HP/10HP/16/ 24E)■ BSMI CNS13438- Safety■ LVD EN60950-1■ BSMI CNS14336-1■ CB IEC60950-1(GS1900-8HP/10HP/16/24E/24)- RoHS compliant.

-Stackable:Yes.

-Form factor:1U.

-PoE:No.

-Average time between failures:432,673 h.


Technical specifications of Zyxel GS1900-24-EU0102F

Features of Zyxel GS1900-24-EU0102F

Color Black

Color

Black

Key differentiators

Technology in Zyxel GS1900-24-EU0102F switch

Energy rating

Warnings

/ 5

1 Reviews

What our customers are saying about Zyxel GS1900-24-EU0102F switch

Write a review about this product

Answer the question

Write your answer

The question has already been answered, thank you very much for trying to help another customer. We will count on you for future questions.

Include AI Generated questions and answers

Ask a technical question about this product

Frequently bought together
Best sellers

Use cases

Best for

Benefits

Ideal buyer profiles

Competitive features

Where it excels

Consider alternatives if...

Verdict

Specs comparison

Specs vs competitors

Similar alternatives to this product
Related products viewed by other shoppers
We think you might be interested in this

You might also be interested in

Tradeinn works with its own stock and with more than 2,000 suppliers connected daily. We update availability in real time to offer you the widest possible catalog, always at the best price. Some products may require additional delivery time depending on supplier availability.

Quick & easy 30-day return

Secure & safe shopping

100% Satisfaction Guaranteed

Always the best online price

Loading image