Please enter your email address and we’ll send you a link to reset your password right away.

Your VIP area awaits in the APP

Log in to the app to manage your account, orders, and exclusive benefits.

Order tracking

Order tracking

Personalized notifications

Personalized notifications

Exclusive offers

Exclusive offers

Staying signed in lets you shop faster, check your orders, and access your favorites without signing in again.

Stay signed in
Log out
top

Sold and shipped by

sales

Free shipping

Return of order

Homepage

Zyxel GS1915-8 switch

Price without code 70.99

RRP:

You save:

Price without subscription

VAT & duties included

No extra charges at delivery.

What is my size?

What is my size?

My virtual fitting room

My virtual fitting room

Single purchase

Add to my pack 

You save:

Buy now in 1 click
Back to PC configurator

Buy this product and earn

Color:

Free shipping

dto_trans discount on shipping

Free assembly

Free removal of old appliance (only with Ader)

Your interest-free financing from with Klarna Paypal

Pay in 3, 4, 6 or up to 12 installments

My virtual fitting room

Other colors available

left
right

Perfect pairings

left
right

Reportar error

Trusted by over 25 million satisfied customers worldwide

Official brand warranty

Quick & easy 30-day return

Features of Zyxel GS1915-8

Product description of Zyxel GS1915-8 switch

Description summary

EU Plug.

Zyxel GS1915-8.

Switch Type:Managed, Switch Layer:L2.

Basic RJ-45 Ethernet switching type ports:Gigabit Ethernet (10/100/1000), Number of basic RJ-45 Ethernet switching ports:8, Console port:RJ-45.

Complete bidirectional (Full duplex).

MAC address table:8000 entries, Switching capacity:16 Gbit/s.

Network standards:IEEE 802.1Q,IEEE 802.1p,IEEE 802.1x,IEEE 802.3,IEEE 802.3ab,IEEE 802.3ad,IEEE 802.3af,IEEE.

Electrical connector:AC-in power connector.

Specifications:

-Quantity of basic RJ-45 Ethernet switching ports:8.

-Basic RJ-45 Ethernet switching type ports:Gigabit Ethernet (10/100/1000).

-Gigabit Ethernet (copper), number of ports:8.

-Electrical connector:AC-in power connector.

-Console port:RJ-45.

-Width:250 mm.

-Depth:104 mm.

-Height:27 mm.

-Weight:620 g.

-AC input voltage:220 -240 V.

-AC input frequency:50 -60 Hz.

-Energy consumption:4.7 W.

-Power source:Alternating current.

-Operating temperature range:0 -40 °C.

-Relative operating humidity:10 -95%.

-Storage temperature range:-40 -70 °C.

-Heat dissipation:16.03 BTU/h.

-Management protocols:SNMP v1,v2,v3, RMON (1,2,3,9).

-Network standards:IEEE 802.1Q, IEEE 802.1p, IEEE 802.1x, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x.

-Support 10G:No.

-Auto MDI / MDI-X:Yes.

-Copper Ethernet cabling.

Technology:10BASE-T,100BASE-TX,1000BASE-T.

-Complete bidirectional (Full duplex):Yes.

-Flow control support:Yes.

-Limit rate:Yes.

-VLAN Support:Yes.

-Storm transmission control:Yes.

-MAC address table:8000 entries.

-Jumbo Frames, support:Yes.

-Switching capacity:16 Gbit/s.

Performance:11.9 Mpps.

-Jumbo frames:9000.

-Save and forward:Yes.

-Number of queues:8.

-Package buffer:525 MB.

-Cables included:Alternating current.

-Quick setup guide:Yes.

-Package weight:1.1 kg.

-User manual:Yes.

-User manual:Yes.

-Package width:302 mm.

-Package depth:227 mm.

-Package height:64 mm.

-DHCP.

Features:

DHCP client.

-IGMP:Yes.

-Supported security algorithms:802.1x RADIUS.

-MAC, address filter:Yes.

-SSH/SSL support:Yes.

-Authentication:Auto VLAN, MAC-based authentication.

-Switch type:Managed.

-Quality of service (QoS) support:Yes.

-Web-based administration:Yes.

-Switch layer:L2.

-MIB, support:RFC 1213 MIB II, RFC 2819, RFC 1215, RFC 1493.

-Product color:Black.

-LED indicators:Yes.

-Electromagnetic compatibility:LVD EN60950-1, BSMI CNS14336-1.

Certification:CE, FCC, C-Tick, Class A, Class B, BSMI CNS13438.

-PoE:No.

-Average time between failures:1144461 h.

-Multicast, support:Yes.


Technical specifications of Zyxel GS1915-8

Features of Zyxel GS1915-8

Color Black

Color

Black

Key differentiators

Technology in Zyxel GS1915-8 switch

Energy rating

Warnings

/ 5

1 Reviews

What our customers are saying about Zyxel GS1915-8 switch

Write a review about this product

Answer the question

Write your answer

The question has already been answered, thank you very much for trying to help another customer. We will count on you for future questions.

Include AI Generated questions and answers

Ask a technical question about this product

Frequently bought together
Best sellers

Use cases

Best for

Benefits

Ideal buyer profiles

Competitive features

Where it excels

Consider alternatives if...

Verdict

Specs comparison

Specs vs competitors

Similar alternatives to this product
Related products viewed by other shoppers
We think you might be interested in this

You might also be interested in

Tradeinn works with its own stock and with more than 2,000 suppliers connected daily. We update availability in real time to offer you the widest possible catalog, always at the best price. Some products may require additional delivery time depending on supplier availability.

Quick & easy 30-day return

Secure & safe shopping

100% Satisfaction Guaranteed

Always the best online price

Loading image