Please enter your email address and we’ll send you a link to reset your password right away.

Your VIP area awaits in the APP

Log in to the app to manage your account, orders, and exclusive benefits.

Order tracking

Order tracking

Personalized notifications

Personalized notifications

Exclusive offers

Exclusive offers

Staying signed in lets you shop faster, check your orders, and access your favorites without signing in again.

Stay signed in
Log out
top

Sold and shipped by

sales

Free shipping

Return of order

Homepage

Trendnet TPE-1620WSF switch

Price without code 446.99

RRP:

You save:

Price without subscription

VAT & duties included

No extra charges at delivery.

What is my size?

What is my size?

My virtual fitting room

My virtual fitting room

Single purchase

Add to my pack 

You save:

Buy now in 1 click
Back to PC configurator

Buy this product and earn

Color:

Free shipping

dto_trans discount on shipping

Free assembly

Free removal of old appliance (only with Ader)

Your interest-free financing from with Klarna Paypal

Pay in 3, 4, 6 or up to 12 installments

My virtual fitting room

Other colors available

left
right

Perfect pairings

left
right

Reportar error

Trusted by over 25 million satisfied customers worldwide

Official brand warranty

Quick & easy 30-day return

Features of Trendnet TPE-1620WSF

Product description of Trendnet TPE-1620WSF switch

Description summary

Enhance your network with the TRENDnet TPE-1620WSF managed switch. This powerful switch features 16 Gigabit PoE+ ports and 4 shared Gigabit ports, offering a robust 370W PoE budget. Offload routing to the switch with L2+ IPv4/IPv6 static routing, while Dynamic ARP Inspection safeguards against attacks. Optimize surveillance with IGMP/MLD snooping and extend reach using SFP slots. Enjoy easy web-based management, comprehensive VLAN support, QoS, and IPv6 capabilities. EU Plug included

EU Plug.

Free up router resources by offloading routing processes to the managed switch by using the L2+ IPv4/IPv6 static routing feature to efficiently route traffic at the switch level.

The dynamic ARP inspection feature helps protect connected devices from man-in-the-middle attacks by discarding malicious and invalid ARP packets.

Take advantage of the available multicast and IGMP/MLD snooping features to optimize IP surveillance system performance, and minimize network traffic.

TRENDnet´s web smart managed switches also feature SFP slots to support long-distance fiber networking applications.

Features:

- 16 x Gigabit PoE+ ports.

- 4 x Shared Gigabit ports (RJ-45 or SFP).

- 370W PoE power budget.

- Easy-to-use web-based management interface.

- Supports IPv6, LACP, VLAN, QoS, and IGMP/MLD Snooping.

- IPv4/IPv6 Static Routing support.

- Bandwidth control per port.

- Private, Multicast, and Voice VLAN support.

- Smart Fans.

- 40Gbps switching capacity.

- IEEE 802.1p QoS with queue scheduling support.

Specifications:

Standards:- IEEE 802.1d.

- IEEE 802.1p.

- IEEE 802.1Q.

- IEEE 802.1s.

- IEEE 802.1w.

- IEEE 802.1X.

- IEEE 802.1ab.

- IEEE 802.3.

- IEEE 802.3u.

- IEEE 802.3x.

- IEEE 802.3z.

- IEEE 802.3ab.

- IEEE 802.3ad.

- IEEE 802.3af.

- IEEE 802.3at.

- IEEE 802.3az Device Interface:- 16 x Gigabit PoE+ ports.

- 4 x Gigabit shared ports (RJ-45 or SFP).

- LED indicators.

- LED Display mode button (toggles LED indicators to display link/activity or PoE only port status) Data Transfer Rate:- Ethernet:10Mbps (half duplex), 20Mbps (full duplex).

- Fast Ethernet:100Mbps (half duplex), 200Mbps (full duplex).

- Gigabit Ethernet:2000Mbps (full duplex) Performance:- Switch fabric:40Gbps.

- RAM buffer:512KB.

- MAC Address Table:8K entries.

- Jumbo Frames:10KB.

- HOL Blocking Prevention.

- Forwarding rate:29.8Mpps (64-byte packet size) Management:- CLI (Telnet / SSHv2) for basic administration.

- HTTP/HTTPS (SSL v2/3 TLS) Web based GUI.

- SNMP v1, v2c, v3.

- RMON v1.

- Static Unicast MAC Address.

- Enable/disable 802.3az Power Saving.

- LLDP and LLDP-MED.

- Virtual Cable Diagnostics Test.

- IPv6:IPv6 Neighbor Discovery, IPv6 Static IP, DHCPv6, Auto configuration.

- Dual image and configuration.

- TC Root/Protect MIB:- IP Forward Table MIB RFC 1354.

- RMON MIB RFC 1271.

- IPv4 MIB RFC 1213.

- IPv6 MIB RFC 2465.

- GVRP MIB IEEE 802.1Q-VLAN.

- LA MIB IEEE 802.3ad.

- LLDP MIB IEEE 802.1ab.

- IGMP Snooping MIB RFC 2933.

- MLD Snooping MIB RFC 3019.

- Private VLAN MIB IEEE 802.1Q.

- DHCP SNOOP MIB RFC 2026.

- QoS MIB RFC 4323.

- SNMP MIB RFC 3415.

- STP MIB RFC 4318.

- PNAC MIB IEEE 802.1x.

- VLAN MIB IEEE 802.1q.

- DNS MIB RFC 1611.

- ACL MIB.

- Bandwidth CTRL MIB.

- LBD MIB.

- Mirror MIB.

- IPv6 NEIGHBOR MIB.

- SNTP MIB.

- Storm CTRL MIB.

- Statistics MIB.

- Tool MIB.

- Voice VLAN MIB.

- DoS MIB Spanning Tree:- IEEE 802.1d STP (Spanning Tree protocol).

- IEEE 802.1w RSTP (Rapid Spanning Tree protocol).

- IEEE 802.1s MSTP (Multiple Spanning Tree protocol) Link Aggregation:- Static Link Aggregation.

- 802.3ad Dynamic LACP Quality of Service (QoS):- 802.1p Class of Service (CoS).

- DSCP (Differentiated Services Code Point).

- Bandwidth Control per port.

- Queue Scheduling:Strict Priority, Weighted Round Robin (WRR) Vlan:- Multiple management VLAN assignment.

- Asymmetric VLAN.

- 802.1Q Tagged VLAN.

- Dynamic GVRP.

- MAC-based VLAN.

- Protocol-based VLAN.

- Up to 256 VLAN groups, ID Range 1-4094.

- Private VLAN (Protected Ports).

- Voice VLAN (10 user defined OUIs) Multicast:- IGMP Snooping v1, v2, v3 (per VLAN).

- MLD Snooping v1, v2.

- IGMP fast leave.

- MVR (Multicast VLAN Registration).

- Static Multicast Address.

- Up to 256 multicast entries.

- Port Mirror.

- RX, TX, or Both.

- Many to one Access Control:- 802.1X Port-Based Network Access Control, RADIUS, TACACS+.

- Local Dial-In User Authentication.

- DHCP Snooping.

- Loopback Detection.

- Duplicated Address Detection.

- Trusted Host.

- Denial of Service (DoS).

- IP MAC port binding.

- Dynamic ARP inspection.

- Block unknown multicast ACL IPv4 L2-L4 & IPv6:- MAC Address.

- VLAN ID.

- Ether Type (IPv4 only).

- IP Protocol 0-255.

- TCP/UDP Port 1-65535.

- 802.1p.

- DSCP (IPv4 only).

- IPv6 Address (IPv6 only) Layer 3.

Features:

.

- IPv4 / IPv6 static routing.

- IP interfaces:Up to 6.

- Routing table entries:Up to 32 (IPv4 / IPv6).

- ARP table (up to 128 entries).

- Inter-VLAN routing Compatibility:- Optional Software Utility:Windows® 10, 8.1, 8, 7, Vista, XP, Windows® 2003/2008 Server.

Power:- Input:100 - 240V AC, 50/60Hz, internal power supply.

- Max.

consumption:460W Poe:- Power Budget:370W.

- 802.3at:Up to 30W per port.

- PoE Mode A:Pins 1, 2, 3, and 6 for power.

- PoE auto/manual classification.

- PoE port priority/power scheduling Fan/Acoustics:- Quantity:2.

- Noise Level:52 dBA (max.).

- Mtbf:192,382 hours.

- Operating Temperature:-5° - 50° C (23° - 122° F).

- Operating Humidity:Max.

90% non-condensing.

- Dimensions:440 x 250 x 44mm (17.3 x 9.8 x 1.74 in.) Rack mountable 1U height.

- Weight:3.89kg (8.5 lbs.) Certifications:- CE.

- FCC.

- UL Package contents:- TPE-1620WSF.

- Quick Installation Guide.

- Power cord (1.8m/6 ft.).

- Rack mount kit.


Technical specifications of Trendnet TPE-1620WSF

Features of Trendnet TPE-1620WSF

Color Black

Color

Black

Key differentiators

Technology in Trendnet TPE-1620WSF switch

Energy rating

Warnings

/ 5

1 Reviews

What our customers are saying about Trendnet TPE-1620WSF switch

Write a review about this product

Answer the question

Write your answer

The question has already been answered, thank you very much for trying to help another customer. We will count on you for future questions.

Include AI Generated questions and answers

Ask a technical question about this product

Frequently bought together
Best sellers

Use cases

Best for

Benefits

Ideal buyer profiles

Competitive features

Where it excels

Consider alternatives if...

Verdict

Specs comparison

Specs vs competitors

Similar alternatives to this product
Related products viewed by other shoppers
We think you might be interested in this

You might also be interested in

Tradeinn works with its own stock and with more than 2,000 suppliers connected daily. We update availability in real time to offer you the widest possible catalog, always at the best price. Some products may require additional delivery time depending on supplier availability.

Quick & easy 30-day return

Secure & safe shopping

100% Satisfaction Guaranteed

Always the best online price

Loading image